Welcome Stranger to OCC!Login | Register

Ultra X-Pro & X-Finity 800watt Power Supplies

Sagittaria    -   March 15, 2007


Testing:
Testing Setup
CPU: Intel Core 2 Duo e6600 @ 3.4ghz 1.5v
    • HSF: Thermal Right Si-128 w/ Silverstone 120MM
Motherboard: eVGA 680i SLI "BR"
Memory: Crucial Ballistix 2x1GB @ 1100mhz 5-5-5-15 2.225V
Video Card: eVGA 8800GTS 640MB
Power Supply: Ultra X-Pro & X-Finity 800W
HDDs: Western Digital 2x80GB 8MB RAID-0
Media: NEC 3550A & Pioneer A06
Sound: Creative Audigy 2 ZS
Operating System: Windows XP SP2

Using this system, I will test idle (nothing running) and load (Every possible thing running). I decided to use ATI Tool's Scan for Artifacts Utility which puts the CPU, RAM, and GPU at load. Unfortunately, I can only measure the voltages using a multimeter as my motherboard does not have any reliable means to measure voltage while in Windows. I'll be using my trusty Etasis 850W as a benchmark, which is also in the same price range. So let's start!

Note: There was no significant difference between 12V rail voltages. I will just measure the 12V from the Molex rail.





The rails are pretty good; well within the specified tolerances. It ran everything I threw at it without a hitch.



  1. Introduction & Closer Look (X-Pro)
  2. Closer Look Continued (X-Pro & X-Finity)
  3. Closer Look Continued (X-Finity & Miscellaneous)
  4. Closer Look Continued (Miscellaneous)
  5. Closer Look Continued (Measurements) & Installation
  6. Specifications
  7. Testing
  8. Testing Continued & Conclusion
Random Pic
© 2001-2014 Overclockers Club ® Privacy Policy

Also part of our network: TalkAndroid, Android Forum, iPhone Informer, Neoseeker, and Used Audio Classifieds

Elapsed: 0.0375158787