Welcome Stranger to OCC!Login | Register

ATI Releases Catalyst 10.7 Drivers

Category: Video Cards
Posted: July 26, 2010 04:53PM
Author: ajmatson


If you're running an ATI card such as the Radeon HD 5870, then you will be interested to know that ATI has updated its drivers. Today ATI released version 10.7 which is said to have new features, fixes, and performance enhancements. According to the release notes, 10.7 fixes several issues with the different operating systems, new features such as Eyefinity and Hydra enhancements, Enhanced pull-down detection, Support for rotated displays with CrossfireX, and GPU acceleration for VLC 1.1.1 media player. ATI also included some performance improvements which according to its tests on Borderlands showed:

  • Performance increases 3-5% on ATI Radeon™ HD 5800 and ATI Radeon™ HD
    5700 series single card and CrossFire™ configurations when anti-aliasing and
    anisotropic filtering is enabled
  • Performance increases 3-8% on ATI Radeon™ HD 5970 single card and
    CrossFire™ configurations when anti-aliasing and anisotropic filtering is enabled
  • Performance increases 2-6% on ATI Radeon™ HD 5600 and ATI Radeon™ HD
    5500 series single card configurations when anti-aliasing and anisotropic filtering
    is enabled
  • Performance increases 2-10% on ATI Radeon™ HD 4800 series single card and
    CrossFire™ configurations when anti-aliasing and anisotropic filtering is enabled

A notable change is ATI included support for Ubuntu 10.4 which will make the Linux users out there happy. To download the new drivers head on over to the ATI Support Site and grab them while their hot. Why you're at it we would love to hear if you notice any performance improvements so be sure to let us know.



Register as a member to subscribe comments.
Locutus on July 26, 2010 05:28PM
2-10% is a huge increase for the 4xxx series, especially seeing as the cards have had so many good updates in the past! Rock on!
Munkypoo7 on July 26, 2010 05:56PM
Shame it bluescreens instantly with my 4870x2 upon boot up... downright sad :(
Waco on July 27, 2010 07:47AM
It works perfectly on mine. :shrug:
Guest comment
Lockheed992 on July 28, 2010 12:30AM
Been getting alot of shader range glitches, like a asteroid in X3 would normally show up as a giant rock but now i have just the front of the rock and everything else missing.

This news has comment postings disabled because it is now archived.

© 2001-2014 Overclockers Club ® Privacy Policy

Also part of our network: TalkAndroid, Android Forum, iPhone Informer, Neoseeker, and Used Audio Classifieds

Elapsed: 0.0517871380