Welcome Stranger to OCC!Login | Register

Catalyst 9.4 Drivers to Axe Card Support

Category: Video Cards, Manufacturers, Software
Posted: March 5, 2009 09:46PM
Author: gebraset

According to a recent report from TC Magazine, the new Catalyst 9.4 drivers coming up from AMD will not support cards that are before the Radeon HD 2000 series. The cards that will supposedly not be supported anymore include professional cards such as the FireGL X1/X2/X3, V3000, V5000, V7000, FireMV 2200, and FireMV 2250. Consumer cards that are said to be on the cut list include Radeon 9500, 9600, 9800, X800, X1800, and X1900 series cards. AMD is claiming that the need for this is so that as a company, it can focus on their newer model cards that are currently in the market now, and that will be released to the public in the near future.



Register as a member to subscribe comments.

This news has comment postings disabled because it is now archived.

© 2001-2014 Overclockers Club ® Privacy Policy

Also part of our network: TalkAndroid, Android Forum, iPhone Informer, Neoseeker, and Used Audio Classifieds

Elapsed: 0.0273239613